We currently experience problems with accessing watermarked assets
Incident Report for Bynder
Resolved
This incident has been resolved.
Posted 7 months ago. Dec 19, 2018 - 13:10 CET
Identified
The issue has been identified and a fix is being implemented.
Posted 7 months ago. Dec 19, 2018 - 13:07 CET
Investigating
We are currently investigating this issue.
Posted 7 months ago. Dec 19, 2018 - 12:25 CET
This incident affected: Asset Library.