Portals less responsive
Incident Report for Bynder
Resolved
This incident has been resolved.
Posted 4 months ago. Mar 29, 2019 - 11:30 CET
Identified
We are having a downgraded performance on our Central European servers. You may experience an overall slower portal.
Posted 4 months ago. Mar 28, 2019 - 16:19 CET
This incident affected: Infrastructure (EU Only).