Statistics aren't displayed correctly in the asset detail page.
Incident Report for Bynder
Resolved
This incident has been resolved.
Posted Apr 14, 2020 - 14:57 CEST
Identified
The issue has been identified and we are working on a solution.
Posted Apr 14, 2020 - 11:50 CEST
This incident affected: Analytics.