Issues with Collections in Global

Incident Report for Bynder

Resolved

This incident has been resolved.
Posted Sep 30, 2025 - 16:47 CEST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 30, 2025 - 16:37 CEST

Identified

The issue has been identified and a fix is being implemented.
Posted Sep 30, 2025 - 16:32 CEST

Investigating

We’re currently investigating reports of issues affecting Collections in Global portals. Users may experience Collections not loading and will see a grey box instead. Our team is working to identify the cause and will share updates as soon as possible.
Until the problem is fixed, the Collections within the Collections page may not load, please watch here for further updates.
Posted Sep 30, 2025 - 16:29 CEST
This incident affected: Collections and Infrastructure (Global).