Degraded performance with Studio in EU-only

Incident Report for Bynder

Resolved

All services are working again as they should be.
Posted Mar 28, 2025 - 11:38 CET

Monitoring

The fix has been deployed, we are monitoring the status.
Posted Mar 28, 2025 - 11:10 CET

Investigating

We are currently experiencing issues with Studio on the services in the EU-only region.
It might happen to portals in this region that Studio shows a "Something went wrong" notification. We are working hard on the solution to this problem and will keep you updated on the progress.
Posted Mar 28, 2025 - 11:06 CET
This incident affected: Studio.