Degraded performance for our global region

Incident Report for Bynder

Resolved

This incident has been resolved.
Posted Mar 09, 2022 - 18:12 CET

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 09, 2022 - 17:03 CET

Update

We are continuing to investigate this issue.
Posted Mar 09, 2022 - 16:42 CET

Investigating

We are seeing some delays while working in our portals, which are on our global services. You may encounter general performance issues when using your portal. Currently, changes made to assets, workflows, collections, etc. are not visible within the portal.
We are investigating the root cause and will continue to provide updates as the investigation develops.
Posted Mar 09, 2022 - 16:25 CET
This incident affected: Asset Library, Uploads, Collections, Asset Workflow and Infrastructure (Global).