Degraded performance with SSO on the US services

Incident Report for Bynder

Resolved

This ticket has been resolved and was part of a business continuity test.
Posted May 28, 2025 - 13:11 CEST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 28, 2025 - 11:55 CEST

Investigating

We are currently experiencing issues with SSO on the services in the US region.
It might happen to portals in this region that SSO will be unavailable, mainly Google SSO. We are working hard on the solution to this problem and will keep you updated on the progress.
Posted May 28, 2025 - 11:23 CEST
This incident affected: Portal Settings.