Issues with Asset Bank in US region

Incident Report for Bynder

Resolved

This incident has been resolved.
Posted Mar 27, 2026 - 15:31 CET

Investigating

We’re currently investigating reports of issues affecting the Asset Bank in the US region. Users may experience delays with assets showing up in Asset Bank after downloading. Our team is working to identify the cause and will share updates as soon as possible.
Posted Mar 27, 2026 - 14:42 CET
This incident affected: Asset Library.