DNS Maintenance
Scheduled for Mar 13, 10:00 - 16:00 CET
Update
We will be undergoing scheduled maintenance during this time.
Posted Feb 23, 2021 - 13:25 CET
Update
We will be undergoing scheduled maintenance during this time.
Posted Feb 23, 2021 - 12:30 CET
Scheduled
On Saturday, Match 13th, 2021 between 10:00 and 16:00 CET we planned DNS maintenance on our bynder.com domain zone.

During this time portals using the ".bynder.com" domain in their URL may be unavailable. The bynder.com website will also be temporarily unavailable during this time.
Please be aware that our knowledge-base (support.bynder.com) and our status page (this page; status.bynder.com) might be unavailable too.
Posted Feb 22, 2021 - 17:29 CET
This scheduled maintenance affects: Asset Library, Uploads, Download, Collections, Workflow, Brandstore, Analytics, Bynder.com, help.bynder.com, POD, Styleguide, Brand Guidelines, Digital Brand Templates, and Video Brand Studio.