Bynder website currently not loading
Incident Report for Bynder
Resolved
This incident has been resolved.
Posted Sep 06, 2024 - 09:21 CEST
Investigating
We are currently experiencing an issue with Bynder's website. This does not affect accessing your custom Bynder DAM.

We apologize for any inconvenience this may cause and appreciate your patience. We will provide updates as soon as more information is available.
Posted Sep 06, 2024 - 01:18 CEST
This incident affected: Bynder Websites (Bynder.com).