Issues with loading of metaproperty options during upload in all regions

Incident Report for Bynder

Resolved

This incident has been resolved.
Posted Apr 09, 2026 - 20:49 CEST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 09, 2026 - 19:55 CEST

Identified

The issue has been identified and a fix is being implemented.
Posted Apr 09, 2026 - 18:36 CEST

Investigating

We’re currently investigating reports of issues affecting the loading of metaproperty options during upload in all regions. Users may experience during upload or edit that metaproperty options will not display. Our team is working to identify the cause and will share updates as soon as possible.
Posted Apr 09, 2026 - 18:35 CEST
This incident affected: Uploads.