Degraded performance in the EU-only region

Incident Report for Bynder

Resolved

This incident has been resolved.
Posted Oct 31, 2024 - 15:43 CET

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 31, 2024 - 12:20 CET

Investigating

We are currently experiencing issues in our EU-only region. Users might experience general performance issues and might not be unable to login. We are working hard on getting these issues resolved.
Posted Oct 31, 2024 - 11:59 CET
This incident affected: Asset Library and Infrastructure (EU Only).