Degraded performance using Internet Explorer 11.
Incident Report for Bynder
Resolved
This incident has been resolved.
Posted 18 days ago. Oct 04, 2019 - 18:12 CEST
Identified
The issue has been identified and a fix is being implemented.
Posted 19 days ago. Oct 04, 2019 - 14:45 CEST
Investigating
We are currently investigating the issue. We advise to use Google Chrome as an alternative until the problem is solved.
Posted 19 days ago. Oct 04, 2019 - 14:25 CEST
This incident affected: Asset Library and Download.