Digital Brand Templates (DBT) Not Loading
Incident Report for Bynder
Resolved
This incident has been resolved.
Posted Apr 05, 2022 - 17:12 CEST
Investigating
Users who access Digital Brand Templates in a portal that is hosted in the US region may experience that the content doesn't load. They may not see any templates.

Our tech teams are working hard on having this resolved as quickly as possible.

We apologize for this inconvenience this may cause you.
Posted Apr 05, 2022 - 16:25 CEST
This incident affected: Digital Brand Templates.