Creative Workflow Assets Not Accessible

Incident Report for Bynder

Resolved

This incident has been resolved.
Posted Nov 16, 2023 - 17:28 CET

Identified

When viewing Creative Workflow assets you may get to see the following error message: "Oops!
Something went wrong displaying this page."

Our tech teams have identified the issue and are working hard on having this resolved as quickly as possible.

We apologize for any inconvenience this may cause you.
Posted Nov 16, 2023 - 16:43 CET
This incident affected: Asset Workflow.