Issues with uploads in EU region

Incident Report for Bynder

Resolved

The issue has been resolved.
All services are working as expected.
Posted Jan 13, 2026 - 17:45 CET

Monitoring

Users might have experienced uploads hanging on converting. We’ve deployed a fix for the issue. Services should be working as expected, but we are monitoring the results to ensure full recovery.
Posted Jan 13, 2026 - 17:41 CET
This incident affected: Uploads and Infrastructure (EU Only).