Issues with login services in the US-only region

Incident Report for Bynder

Resolved

The issues have been resolved. No users should have been impacted due to an automatic failover to backup services.
Posted Jun 03, 2026 - 11:27 CEST

Investigating

We’re currently investigating internal reports of issues affecting login services the US-only region. Users may experience issues while logging in. Our team is working to identify the cause and will share updates as soon as possible. Traffic is automatically being rerouted to backup services, so users should not experience any issues.
Posted Jun 03, 2026 - 10:46 CEST
This incident affected: Asset Library and Infrastructure (US Only).