Intermittent timeouts in Global region

Incident Report for Bynder

Resolved

This incident has been resolved.
Posted Feb 27, 2026 - 13:44 CET

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 27, 2026 - 12:37 CET

Identified

We’re currently investigating reports of intermittent time outs errors (504) in the Global region. Users may experience their portals being slow to respond or timing out.

Our team has identified the cause and it's working on a resolution.
Posted Feb 27, 2026 - 12:22 CET
This incident affected: Infrastructure (Global).