Slower Uploads

Incident Report for Bynder

Resolved

This incident has been resolved.
Posted Feb 20, 2025 - 08:32 CET

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 19, 2025 - 19:53 CET

Investigating

We are currently experiencing delays uploading new media into the asset bank.

Our tech team are working hard on having this issue resolved as quickly as possible. We apologize for any inconvenience this may cause you.
Posted Feb 19, 2025 - 17:35 CET
This incident affected: Asset Library.