Degraded performance with the UCV in the Global region

Incident Report for Bynder

Resolved

This incident has been resolved.
Posted Aug 07, 2025 - 19:40 CEST

Identified

The issue has been identified and a fix is being implemented.
Posted Aug 07, 2025 - 18:27 CEST

Investigating

We are currently experiencing issues with the Universal Compact View (UCV) on the services in the Global region.
It might happen to portals in this region that the UCV will load with a error message of Oops Something went wrong!. We are working hard on the solution of this problem and will keep you updated on the progress.
Posted Aug 07, 2025 - 16:53 CEST
This incident affected: Asset Library and Infrastructure (Global).