Asset bank module - Asset bank may appear to be empty
Incident Report for Bynder
Resolved
This incident has been resolved.
Posted Mar 19, 2024 - 15:35 CET
Investigating
We are currently experiencing issues with our asset bank module.
It might happen that the asset bank appears to be empty. We are working hard on the solution of this problem and will keep you updated on the progress.
Posted Mar 19, 2024 - 15:10 CET
This incident affected: Asset Library.