Download Issues for Files over 10GB
Incident Report for Bynder
Resolved
This incident has been resolved.
Posted Sep 03, 2021 - 14:22 CEST
Investigating
Users may not be able to download assets that are over 10GB. The download may not start and an error message may be shown. Our tech teams are working hard on having this resolved as quickly as possible.

We apologize for any inconvenience this may cause you.
Posted Sep 03, 2021 - 13:00 CEST
This incident affected: Download.