Degraded performance with Bynder Express in EU-Only.
Incident Report for Bynder
Resolved
This incident has been resolved.
Posted Feb 14, 2024 - 13:38 CET
Identified
We are currently experiencing issues with Bynder Express in the EU region.
It might happen to portals in this region that files can't be transferred via Bynder Express.
We are working hard on the solution of this problem and will keep you updated on the progress.
Posted Feb 14, 2024 - 12:29 CET
This incident affected: Bynder Express.