Issues with downloads in global region

Incident Report for Bynder

Resolved

This incident has been resolved.
Posted Sep 25, 2025 - 17:24 CEST

Monitoring

We’ve deployed a fix for the issue. Services should be working as expected, but we are monitoring the results to ensure full recovery.
Posted Sep 25, 2025 - 14:00 CEST

Identified

We’ve identified the cause of the issue. Our team is implementing a fix and will provide an update once the solution is deployed.
Posted Sep 25, 2025 - 13:53 CEST

Investigating

We’re currently investigating reports of issues affecting downloads in our global region. Users may experience (batch) downloads not starting. Our team is working to identify the cause and will share updates as soon as possible.
Posted Sep 25, 2025 - 13:47 CEST
This incident affected: Downloads and Infrastructure (Global).