Video Brand Studio Doesn't Load
Incident Report for Bynder
Resolved
This incident has been resolved.
Posted Mar 09, 2021 - 16:30 CET
Investigating
Users using Video Brand Studio will experience that the module doesn't load. Our tech teams are working hard on having this resolved as quickly as possible.

We apologize for any inconvenience this may cause you.
Posted Mar 09, 2021 - 16:20 CET
This incident affected: Video Brand Studio.