Global region - Degraded performance - navigation bar might not load
Incident Report for Bynder
Resolved
This incident has been resolved.
Posted Apr 17, 2024 - 16:44 CEST
Investigating
We are currently experiencing issues with the navigation bar in our global region.

It might happen that it takes longer for the navigation bar to load, or not load at all.

We are working hard on the solution of this problem and will keep you updated on the progress.
Posted Apr 17, 2024 - 15:41 CEST
This incident affected: Asset Library and Infrastructure (Global).