Global region - Degraded performance with the asset bank

Incident Report for Bynder

Resolved

This incident has been resolved.
Posted Jul 11, 2025 - 12:08 CEST

Update

We are continuing to monitor for any further issues.
Posted Jul 11, 2025 - 12:08 CEST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 11, 2025 - 11:50 CEST

Investigating

We are currently experiencing issues with the asset bank.
You might experience the following issues:
- Uploads failing
-Downloads failing
- No image previews
We are working hard on getting the issues resolved
Posted Jul 11, 2025 - 11:50 CEST
This incident affected: Asset Library, Uploads, and Downloads.