Database maintenance on Global and EU-only services
Scheduled for Jun 1, 09:00 - 19:00 CEST
Update
Because of complications we experienced during the planned maintenance of the EU-only services, planned for May 4th, we were not able to execute our plans that day.
This maintenance still needs to be done on the EU-only services, which are now planned to do together with the Global services on June 1st 2024.

So;
On Saturday, June 1st between 9:00 and 19:00 CEST 2024, we planned maintenance on our Global and EU-only services.
This means the services of Bynder on the Global and EU-only offerings might occasionally not be available during this time frame.
Posted May 22, 2024 - 11:52 CEST
Scheduled
On Saturday, June 1st between 9:00 and 19:00 CEST 2024, we planned maintenance on our Global services.
This means the services of Bynder on the Global offering might occasionally not be available during this time frame.
Posted Apr 23, 2024 - 14:17 CEST
This scheduled maintenance affects: Infrastructure (Global, EU Only).