Open Asset Bank Portals Inaccessible

Incident Report for Bynder

Resolved

This incident has been resolved.
Posted Apr 16, 2026 - 19:10 CEST

Investigating

Customers using an Open Asset Bank, where parts of the DAM are accessible without logging in, may currently experience issues accessing it. Our technical teams are investigating the problem and working to resolve it as quickly as possible. We apologize for any inconvenience caused.
Posted Apr 16, 2026 - 18:06 CEST
This incident affected: Asset Library and Infrastructure (Global, US Only, EU Only).