Brand Guidelines cannot be edited
Incident Report for Bynder
Resolved
This incident has been resolved.
Posted Apr 07, 2020 - 17:40 CEST
Investigating
Editing Brand Guidelines is currently not working since 9:30 Eastern Time. Users on our US server may run into this issue. Our tech teams are working on having this resolved as quickly as possible.
Posted Apr 07, 2020 - 16:34 CEST
This incident affected: Infrastructure (US Only) and Brand Guidelines.