Download issues when disclaimer is enabled
Incident Report for Bynder
Resolved
This incident has been resolved.
Posted 4 months ago. Mar 19, 2019 - 14:53 CET
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 4 months ago. Mar 19, 2019 - 14:16 CET
Investigating
We are currently experiencing issues with downloading files when a disclaimer is enabled. We are investigating the issue
Posted 4 months ago. Mar 19, 2019 - 14:01 CET
This incident affected: Download.