Degraded performance with downloads in Global

Incident Report for Bynder

Resolved

The issue has been resolved.
All services are working as expected.
Posted May 27, 2026 - 11:42 CEST

Monitoring

Services should be working as expected, but we are monitoring the results to ensure full recovery.
Posted May 27, 2026 - 07:37 CEST

Investigating

We're currently investigating reports of issues affecting batch downloads in the Global region. Users may experience batch downloads failing; single-file downloads continue to work. Our team is working to identify the cause and will share updates as soon as possible.
Posted May 27, 2026 - 07:06 CEST
This incident affected: Downloads.