Internet Explorer 11 issues
Incident Report for Bynder
Resolved
The issue has been resolved and users can use Internet Explorer 11 again.
Posted Mar 03, 2020 - 17:58 CET
Identified
Users may run into issues when using Internet Explorer 11 and experience an unresponsive portal. Main functionalities such as uploading, downloading, viewing and/or filtering assets may, therefore, not work.

As a workaround we advise to make use of a different browser. Our tech teams are working hard on having this issue resolved as quickly as possible.
Posted Mar 03, 2020 - 17:24 CET
This incident affected: Asset Library, Uploads, Download, Collections, Creative Workflow, Brandstore, and Analytics.