Global Download Issue
Incident Report for Bynder
Resolved
This incident has been resolved.
Posted Mar 16, 2022 - 09:09 CET
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 15, 2022 - 20:49 CET
Update
We are continuing to work on a fix for this issue.
Posted Mar 15, 2022 - 20:10 CET
Identified
We are experiencing an issue downloading on all portals. You may see a “checking disclaimer” or “we are preparing your download” error. We are working diligently on a resolution and will keep you updated on the progress.
Posted Mar 15, 2022 - 20:04 CET
This incident affected: Asset Library and Download.