Issues with degraded performance in EU-Only

Incident Report for Bynder

Resolved

The issue has been resolved.
All services are working as expected.
Posted Nov 05, 2025 - 16:04 CET

Monitoring

We’ve deployed a fix for the issue. Services should be working as expected, but we are monitoring the results to ensure full recovery.
Posted Nov 05, 2025 - 14:21 CET

Identified

We’ve identified the issue, which affects only a small number of customers in the EU-Only region. Our team is working on a fix and will share an update shortly.
Posted Nov 05, 2025 - 12:49 CET

Investigating

We’re currently investigating reports of issues affecting performance in our EU-Only region. Users may experience Asset thumbnails not loading. Our team is working to identify the cause and will share updates as soon as possible.
Posted Nov 05, 2025 - 11:02 CET
This incident affected: Asset Library and Infrastructure (EU Only).