Degraded performance IE

Incident Report for Bynder

Resolved

This incident has been resolved.
Posted Oct 29, 2019 - 18:17 CET

Investigating

We are currently investigating an issue regarding degraded performance using Internet Explorer.
Therefore we strongly recommend to use Google Chrome till the issue has been resolved.
Posted Oct 29, 2019 - 16:09 CET
This incident affected: Asset Library.