Portal access delays for Global portal
Incident Report for Bynder
Resolved
This incident has been resolved.
Posted May 15, 2024 - 19:51 CEST
Identified
The issue has been identified and we continue working on a solution.
Posted May 15, 2024 - 19:26 CEST
Investigating
We see some delays when accessing or navigating within portals, which are on our Global services. You may encounter login as well as general performance issues when accessing and using your portal.
We are investigating the root cause and will continue to provide updates as the investigation develops.
Posted May 15, 2024 - 17:47 CEST
This incident affected: Infrastructure (Global).