Issues with asset uploads in Global

Incident Report for Bynder

Resolved

This incident has been resolved.
Posted Sep 26, 2025 - 00:39 CEST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 25, 2025 - 23:14 CEST

Investigating

We’re currently investigating reports of issues affecting asset uploads in the Global region. Users may experience delays or errors while uploading assets to portals in the Global region. Our team is working to identify the cause and will share updates as soon as possible.
Posted Sep 25, 2025 - 22:25 CEST
This incident affected: Asset Library and Infrastructure (Global).