Degraded performance on our US West servers (Business Continuity Test)
Incident Report for Bynder
Resolved
This incident has been resolved.
Posted Oct 20, 2020 - 17:20 CEST
Identified
We experience degraded performance on our US West servers caused by a Business Continuity Test.
All US client portals are redirected to our US East servers and users should no longer experience downtime.

Our tech teams are working hard on having this resolved as quickly as possible.
Posted Oct 20, 2020 - 13:40 CEST
This incident affected: Infrastructure (US Only).