Issues with downloads in Global region and EU region

Incident Report for Bynder

Resolved

This incident has been resolved.
Posted Aug 27, 2026 - 17:54 CEST

Update

We are continuing to monitor for any further issues.
Posted Aug 27, 2026 - 17:19 CEST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 27, 2026 - 17:18 CEST

Identified

The issue has been identified and a fix is being implemented.
Posted Aug 27, 2026 - 16:47 CEST

Investigating

We’re currently investigating reports of issues with downloading assets in the Global and EU region. Users may experience that downloads do not initiate. Our team is working to identify the cause and will share updates as soon as possible.
Posted Aug 27, 2026 - 15:55 CEST
This incident affected: Downloads.