Bynder Analytics Incident

Incident Report for Bynder

Resolved

This incident has been resolved.
Posted Jul 29, 2023 - 16:31 CEST

Investigating

The Bynder Analytics dashboard may display inaccurate data or may not load. Our tech teams are working hard on having this issue resolved as quickly as possible. We apologize for any inconvience this may cause you.
Posted Jul 29, 2023 - 13:09 CEST
This incident affected: Analytics.