Unable to Access Analytics

Incident Report for Bynder

Resolved

This incident has been resolved.
Posted May 20, 2020 - 21:41 CEST

Investigating

We are currently investigating an error with the Analytics Module. Users in EU may not be able to access the module.
Posted May 20, 2020 - 21:20 CEST
This incident affected: Analytics.