Degraded performance with Studio Solution in Global region

Incident Report for Bynder

Resolved

We have identified and solved the issue.
All services are working again as they should be.
Posted May 09, 2025 - 13:30 CEST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 09, 2025 - 13:18 CEST

Investigating

We are currently experiencing issues with our Studio Solution on the services in the Global region.
Portals in this region might experience problems loading the Studio Solution. We are working hard to solve this problem and will keep you updated on the progress.
Posted May 09, 2025 - 12:32 CEST
This incident affected: Studio.