Degraded performance with Print Brand Templates in all regions

Incident Report for Bynder

Resolved

This incident has been resolved.
Posted Apr 14, 2025 - 22:49 CEST

Identified

The issue has been identified and a fix is being implemented.
Posted Apr 14, 2025 - 22:30 CEST

Investigating

We are currently experiencing issues with Print Brand Templates on the services in the all regions.
It might happen to portals with Print Brand templates that creating a template asset will not save. We are working hard on the solution of this problem and will keep you updated on the progress.
Posted Apr 14, 2025 - 22:04 CEST
This incident affected: Print Brand Templates.