Studio isn't loading

Incident Report for Bynder

Resolved

This incident has been resolved.
Posted Jul 25, 2024 - 16:16 CEST

Identified

You may experience that our Studio module is not loading.
Our tech teams have identified the issue and are working hard on having this issue resolved as quickly as possible.

We apologize for any inconvenience this may cause you.
Posted Jul 25, 2024 - 15:10 CEST
This incident affected: Studio.