Degraded performance with Bynder Express

Incident Report for Bynder

Resolved

We have identified and solved the issue.
All services are working again as they should be.
Posted Jul 15, 2025 - 12:07 CEST

Investigating

We are currently experiencing issues with the Bynder Express feature.
It might happen to portals that the receiver of the Bynder Express link will get a 500 error when clicking the download link. We are working hard on the solution of this problem and will keep you updated on the progress.
Posted Jul 15, 2025 - 11:46 CEST
This incident affected: Bynder Express.